Z SCORE EEG BIOFEEDBACK: TECHNICAL FOUNDATIONS

Robert W. Thatcher, Ph.D., Carl J. Biver, Ph.D. and Duane M. North, MA.
NeuroImaging Laboratory, Applied Neuroscience, Inc.
7985 113th Street North, Suite 210, Seminole, FL 33772
www.appliedneuroscience.com

1.0 - Design of the Instantaneous Z Score Normative Database

The number of subjects (N = 625), selection criteria, age range (2 months to 82 years), cross-validation tests, demographics, and other details of the Z score normative database have been published and are recommended reading for those interested in deeper details than is briefly reviewed in this paper (see Thatcher et al, 1983; 1986; 1987; Wolf and Thatcher, 1990; Thatcher, 1998a; 1998b; Thatcher et al, 2003). There are four basic concepts used in the design of Z score biofeedback as described below:

1.1- Use of Gaussian Probabilities to Identify “De-Regulation” in the Brain

The fundamental design concepts of Z score biofeedback were first introduced by Thatcher (1998a; 1998b; 2000a; 2000b). The central idea of the instantaneous Z score is the application of the mathematical Gaussian curve or ‘Bell Shaped’ curve by which probabilities can be estimated using the auto and cross-spectrum of the electroencephalogram (EEG) in order to identify brain regions that are de-regulated and depart from expected values. Linkage of symptoms and complaints to functional localization in the brain is best achieved by the use of a minimum of 19 channel EEG evaluation so that current source density and LORETA source localization can be computed. Once the linkage is made, then an individualized Z score protocol can be devised. However, in order to make a linkage to symptoms an accurate statistical inference must be made using the Gaussian distribution. The Gaussian distribution is a fundamental distribution that is used throughout science, for example, the Schrodinger wave equation in Quantum mechanics uses the Gaussian distribution as basis functions (Robinett, 1997). The application of the EEG to the concept of the Gaussian distribution requires the use of standard mathematical transforms by which all statistical distributions can be transformed to a Gaussian distribution (Box and Cox, 1964). In the case of the EEG, transforms such as the square root, cube root; log10, Box-Cox, etc. are applied to the power spectrum of the digital time series in order to approximate a normal distribution (Gasser, et al, 1988a; 1988b; John et al, 1987; 1988, Duffy et al, 1994; Thatcher et al, 2003; 2005a; 2005b). The choice of the exact transform depends on the accuracy of the approximate match to a Gaussian distribution. The fact
that accuracies of 95% to 99% match to a Gaussian are commonly published in the EEG literature encouraged Thatcher and colleagues to develop and test the Z score biofeedback program.

1.2 – Application of Gaussian Probability Distributions to Instantaneous Z Score Biofeedback and why JTFA Z Scores are smaller than FFT Z Scores

The second design concept is the application of the Gaussian distribution to averaged “instantaneous” time domain spectral measures from groups of normal subjects and then to cross-validate the means and standard deviations for each subject for each instant of time (Thatcher, 1998a; 1998b, 2000a; 2000b). The cross-validation is directly related to the variance of the distribution (Thatcher et al, 2003; 2005a; 2005b). However, in order to achieve a representative Gaussian distribution it is necessary to include two major categories of statistical variance; 1- the moment-to-moment variance or within session variance and, 2- between subject variance across an age group. In the case of the Fast Fourier Transform (FFT) there is a single “integral” of the power spectrum for each subject and each frequency and, therefore, there is only between subject variance in normative databases that use non-instantaneous analyses such as the FFT. Thus, there is a fundamental and important difference between an instantaneous Z score and an integrated FFT Z score with the former having two sources of variance while the latter has only one source of variance. Figure 1 is a diagram to illustrate the relationship between an FFT based normative database versus an “instantaneous” or Joint Time Frequency Analysis (JTFA) database such as used for the computation of instantaneous Z scores.
Fig. – 1. JTFA normative databases are instantaneous and include within session variance plus between subject variance. In contrast, FFT normative data only contains between subject variance. \( t = \text{time}, s = \text{subjects} \) and \( SD_t = \text{standard deviation for the within session} \) and \( SD_s = \text{standard deviation between subjects.} \) Thus FFT \( Z \) scores are larger than JTFA \( Z \) scores and a ratio of 2:1 is not uncommon.

1.3 – Simplification and Standardization

The third design concept is simplification and standardization of EEG biofeedback by the application of basic science. Simplification is achieved by the use of a single metric, namely, the metric of the “Z Score” for widely diverse measures such as power, coherence and phase delays. Standardization is also achieved by EEG amplifier matching of the frequency response of the normative database amplifiers to the frequency characteristics of the EEG amplifiers used to acquire a comparison subject’s EEG time series.

1.4 – Individualized EEG Biofeedback Protocols

A fourth and intertwined clinical concept in the design of Z score biofeedback is “individualized” EEG biofeedback and non-protocol drive EEG biofeedback. The idea of linking patient symptoms and complaints to functional localization in the brain as evidenced by “de-regulation” of neural populations is fundamental to individualized biofeedback. For example, de-regulation is recognized by significantly elevated or
reduced power or network measures such as coherence and phase within regions of the brain that sub-serve particular functions that can be linked to the patient’s symptoms and complaints. The use of Z scores for biofeedback is designed to “re-regulate” or “optimize” the homeostasis, neural excitability and network connectivity in particular regions of the brain. The functional localization and linkage to symptoms is based on modern knowledge of brain function as measured by fMRI, PET, penetrating head wounds, strokes and other neurological evidence acquired over the last two centuries (see Heilman and Valenstein, 1993; Braxis et al, 2007 see the Human Brain Mapping database of functional localization at: http://hendrix.imm.dtu.dk/services/jerne/brede/index_ext_roots.html). Thus, the false concern that Z score biofeedback will make exceptional people dull and an average individual a genius is misplaced. The concept is to link symptoms and complaints and then monitor improvement or symptom reduction during the course of treatment. For peak performance applications, a careful inventory of the client’s personality style, self assessment of weaknesses and strengths and identification of the client’s specific areas that he/she wishes to improve must be obtained before application of Z score biofeedback. Then, the practitioner attempts to link the client’s identification of areas of weakness that he/she wants improved to functional localization as expressed by “de-regulation” of deviant neural activity that may be subject to change.

As mentioned previously, the instantaneous Z scores are much smaller than the FFT Z scores in NeuroGuide™ which uses the same subjects for the normative database. Smaller Z scores when using the instantaneous Z scores is expected as described in section 1.2. One should not be surprised by a 50% reduction in JTFA Z scores in comparison to FFT Z scores and this is why it is best to first use 19 channel EEG measures and the highly stable FFT Z scores to link symptoms to functional localization in the brain to the extent possible. Then use the Z Score program inside of NeuroGuide™ to evaluate the patient’s instantaneous Z scores in preparation before the biofeedback procedure begins. This will allow one to obtain a unique picture of the EEG instantaneous Z scores of each unique patient prior to beginning Z score biofeedback. The clinician must be trained to select which Z scores best match the patient’s symptoms and complaints. A general rule is choice of Z scores to use for biofeedback depends on two factors obtained using a full 19 channel EEG analysis: 1- scalp location(s) and, 2- magnitude of the Z scores. De-regulation by hyperpolarization produces slowing in the EEG and de-regulation due to reduced inhibition produces deviations at higher frequencies. The direction of the Z score is much less important than the location(s) of the deviant Z scores and the linkage to the patient’s symptoms and complaints.

Here is a step by step description of how to review your patient’s EEG prior to designing a Z score biofeedback protocol. The Z score biofeedback program inside of NeuroGuide™ is the same program as used by BrainMaster, Thought Technology, EEG Spectrum, Mind Media BV (NeXus) and Deymed.

1.5 – Step-by-Step Instantaneous Z Score Tutorial inside of NeuroGuide™

Before beginning the step by step tutorial, please download the free NeuroGuide Demo at http://www.appliedneuroscience.com/Contact%20Download1.htm. Install
and launch NeuroGuide, accept the copyright agreement and then click Demo. If one is a current user of NeuroGuide™ then rename the file c:/program files/NeuroGuide/passKeyB to oldpassKeyB and then launch NeuroGuide and click Demo.

Step 1- Click File Open > Lexicor > Lexicor NRS24. This is the EEG from a 55 yr. old male who was struck by a bat near to his right parietal bone and suffered a slow bleeding epidural hematoma. The day following the incident the patient was found on the floor and unresponsive and the CT scan showed blood had pocketed in the occipital region and drainage of the blood in the occipital region was ordered. Two years post incident the patient has spatial neglect, is in a wheel chair due to paralysis of his left side and has denial of the extent of his disorder and problems recognizing emotions in others. We expect to find P4 to be deviant from normal based on clinical symptoms.

Step 2- In the Subject Information window, for age type 55 and select the eyes closed condition and click ok.

Step 3- Double click Linked Ears in the Montage list on the left side of the screen.

Step 4- Edit > Select All and then Click View > Dynamic FFT > Absolute Power and position the mouse over the Z score of Absolute Power panel and depress the left mouse button and move the mouse to 5.5 Hz and view the elevated Z scores in C4 and P4. Select all is not a recommended option in NeuroGuide™ because it contains artifact and is only used here for illustration purposes.

Step 5- Click View > Dynamic JTFA > Absolute Power

Step 6- Click View > Dynamic JTFA > Z Scores

Step 7- Click View > Dynamic JTFA > Color Maps

Step 8 – Depress the left mouse button and drag the mouse over the EEG tracings and view the dynamic Z scores in the delta, theta, alpha, beta and hi-beta frequency bands. Depress the left mouse button and move the mouse to the right border and automatically advance the instantaneous Z scores like a movie.

Step 9- Change the display time to 1 second (located in the lower left corner) and review your patient’s instantaneous Z scores for all 19 locations like a temporal zoom lenz.
Figure 2 is an example of the instantaneous Z score screen inside of NeuroGuide™ while the instantaneous Z scores are being reviewed.

A P4 and C4 theta and delta deviation from normal is evident as well as bilateral occipital delta deviations from normal. There is diminished alpha and theta but in the instantaneous Z scores but on the average the dynamic FFT provides a much clearer picture of the right parietal and right central Z scores. For illustration purposes only, a biofeedback protocol would be to reward Z score values less than and greater than 2 standard deviations in the theta frequency band in P4 and C4 and most of the feedback rewards will automatically occur in the delta and theta frequency band. As mentioned previously, the above is an example of an individualized Z score biofeedback procedure after reviewing the patent’s EEG using the same instantaneous Z score program running in BrainMaster, Thought Technology, EEG Spectrum, Mind Media BV (NeXus) and Deymed.

2.0 - Implementation of the Z Score Biofeedback
Step one is to compute means and standard deviations of instantaneous absolute power, relative power, power ratios, coherence, phase differences and amplitude asymmetries on selected age groups of normal subjects from the 19 channel 10/20 electrode locations using the within session and between session variance as described previously. The inclusion/exclusion criteria, number of subjects, number of subjects per age group, cross-validation procedures and other details of the means and standard deviation computations is published (Thatcher et al, 1987; 2003) and shown in Figure 5. Step two is to develop a Dynamic Link Library or DLL that can be distributed to EEG biofeedback manufacturers such as BrainMaster, EEG Spectrum, Thought Technology, Mind Media BV (NeXus) and Deymed which allows the manufacturers to integrate the instantaneous Z scores inside of their already existing software environments. The dll involves only four command lines of code and is designed for software developments to easily implement the instantaneous Z scores by passing raw digital data to the dll and then organizing the Z scores that are returned in less than one microsecond. This rapid analysis and return of Z scores is essential for timely feedback when specific EEG features are measured by the Complex Demodulation JTFA operating inside of the dll.

2.1 – JTFA Complex Demodulation Computations

The mathematical details of complex demodulation used to compute the instantaneous Z scores as contained in the Applied Neuroscience, Inc. “dll” are provided in the Appendix section 4.0 and are described in Otnes and Enochson, 1977; Granger and Hatanaka, 1964; Bloomfield, 2000; Thatcher et al, 2007). Complex demodulation is a time domain digital method of spectral analysis whereas the fast Fourier transform (FFT) is a frequency domain method. These two methods are related by the fact they both involve sines and cosines and both operate in the complex domain and in this way represent the same mathematical descriptions of the power spectrum. The advantage of complex demodulation is that it is a time domain method and less sensitive to artifact and it does not require windowing nor even integers of the power of 2 as does the FFT. The FFT integrates power in a frequency band over the entire epoch length and requires windowing functions which can dramatically affect the power values whereas, as mentioned previously, complex demodulation does not require windowing (Otnes and Enochson, 1972). Complex demodulation was computed for the linked ears and eyes open and eyes closed conditions for all 625 subjects in the normative database.

Table I – Time Domain Conversion of Frequencies to Time of the Z Score

<p>| Biofeedback DLL and NeuroGuide. The asterisk * = NeuroGuide Only |
|----------------|----------------|----------------|
| <strong>Center Frequency</strong> | <strong>Band Width</strong> | <strong>Time Domain</strong> |
| Delta | 2.5 Hz | 1 – 4 Hz | 1,000 ms to 250 ms |
| Theta | 6.0 Hz | 4 - 8 Hz | 250 ms to 125 ms |
| Alpha | 8.0 Hz | 8 – 12 Hz | 125 ms to 83 ms |
| Beta | 18.5 Hz | 12 – 25 Hz | 83 ms to 40 ms |
| Hi-Beta | 27.5 Hz | 25 – 30 Hz | 40 ms to 33 ms |</p>
<table>
<thead>
<tr>
<th>Beta 1</th>
<th>13.5 Hz</th>
<th>12 – 15 Hz</th>
<th>83 ms to 67 ms</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beta 2</td>
<td>16.5 Hz</td>
<td>15 – 18 Hz</td>
<td>67 ms to 56 ms</td>
</tr>
<tr>
<td>Beta 3</td>
<td>21.5 Hz</td>
<td>18 – 25 Hz</td>
<td>56 ms to 40 ms</td>
</tr>
<tr>
<td>Alpha 1</td>
<td>9.0 Hz</td>
<td>8 – 10 Hz</td>
<td>125 ms to 100 ms</td>
</tr>
<tr>
<td>Alpha 2</td>
<td>11.0 Hz</td>
<td>10 – 12 Hz</td>
<td>100 ms to 83 ms</td>
</tr>
<tr>
<td>Gamma 1*</td>
<td>FFT only</td>
<td>30 – 35 Hz</td>
<td>33 ms to 29 ms</td>
</tr>
<tr>
<td>Gamma 2*</td>
<td>FFT only</td>
<td>35 – 40 Hz</td>
<td>29 ms to 25 ms</td>
</tr>
<tr>
<td>Gamma 3*</td>
<td>FFT only</td>
<td>40 – 50 Hz</td>
<td>25 ms to 20 ms</td>
</tr>
</tbody>
</table>

Figure 3 is an illustration of the method of complex demodulation for the computation of power, coherence and phase. The mathematical details are in the Appendix, section 4.0.

Fig. 3 – Diagram of complex demodulation. Left is a sine wave as input which is multiplied by the sine and cosine waves at the center frequency of a given frequency band as described in Table I which transforms the digital time series to the complex plane. A 6th order Butterworth low-pass filter is used to shift the frequency to zero where power at the center frequency is then calculated using the Pythagorean theorem. Complex numbers are then used to compute coherence and phase as described in Appendix, section 4.0.

2.2 - Z Scores and QEEG Normative Databases
Matousek and Petersen (1973) computed means and standard deviations in one year age groups and were the first to use Z scores to compare an individual to the normative database means and standard deviations. The Z score is an excellent statistic defined as the difference between the value from an individual and the mean of the population divided by the standard deviation of the population or 

\[ Z = \frac{x_i - \bar{X}}{SD} \]

John and colleagues expanded on the use of the Z score for clinical evaluation including the use of multivariate measures such as the Mahalanobis distance metric. A direct normalization of the Gaussian distribution using Z scores is useful in comparing individuals to a QEEG normative database. That is, the standard score form of the Gaussian is where the mean = 0 and standard deviation = 1 or, by substitution into the Gaussian equation for a bell shaped curve, then

\[ Y = \frac{1}{\sqrt{2\pi}} e^{-\frac{z^2}{2}} \]

where Y = Gaussian distribution and the Z score is a deviation in standard deviation units measured along the baseline of the Gaussian curve from a mean of 0 and a standard deviation = 1 and deviations to the right of the mean being positive and those to the left negative. By substituting different values of Z then different values of Y can be calculated. For example, when Z = 0, Y = 0.3989 or, in other words, the height of the curve at the mean of the normal distribution in standard-score form is given by the number 0.3989. For purposes of assessing deviation from normal, the values of Z above and below the mean, which include 95% of the area of the Gaussian is often used as a level of confidence necessary to minimize Type I and Type II errors. The standard-score equation is also used to cross-validate a normative database which again emphasizes the importance of approximation to a Gaussian for any normative QEEG database.

### 2.3 – Standardization by Amplifier Matching and QEEG Normative Databases

Surprisingly, matching of amplifier frequency characteristics as a standard was largely neglected during much of the history of QEEG normative databases. E. Roy John and colleagues (1982 to 1988) formed a consortium of universities and medical schools that were using QEEG who met several times over a few years and was one of the supporters of the edited volume by John titled “Machinery of the Mind” (John, 1990). One of the important issues consistently raised at the consortium meetings was the need for “standardization”. In the 1980s it was technically difficult to match different EEG systems because of the infantile development of analysis software. This history forced most QEEG uses to use relative power because absolute power was not comparable between different EEG machines. There was no frequency response standardization between different EEG machines and thus there was no cross-platform standardization of QEEG. It was not until the mid 1990s that computer speed and software development made amplifier matching and normative database amplifier equilibration a possibility. The first use of standardized matching of amplifiers was to the University of Maryland (UM) database (Thatcher et al, 2003). The procedure involved injecting micro volt calibration sign waves into the input of amplifiers of different EEG machines and then inject the same micro volt signals into the normative database amplifiers thus obtaining two frequency response curves. Equilibration of a
normative QEEG database to different EEG machines is the ratio of the frequency response curves of the two amplifiers that are then used as coefficients in the power spectral analysis. This was an important step because suddenly absolute power Z scores and normative database comparisons became possible. The frequencies in absolute power are independent of each other and are not distorted. It is always best to use absolute values when ever possible and not relative values or even ratios. A ratio can change due to the denominator or the numerator and one can not determine which has changed without evaluating the absolute values used to compute the ratios.

As illustrated in Figure 4, a simple method of amplifier equilibration to exactly match the frequency characteristics of different amplifiers is to calibrate the amplifiers using micro-volt sine waves at discrete frequencies from 1 to 40 Hz and injecting the sine waves into the inputs of the EEG amplifiers. Then take the ratio of the micro-volt values at each frequency and use the ratios to exactly equate the spectral output values at different frequencies for different amplifiers. This method creates a universal equilibration process so that micro-volts in a given amplifier are equal to micro-volts in all other amplifiers including the normative database amplifiers. By equilibrating amplifiers then direct comparisons between a given patient’s EEG and the normative database means and standard deviations is valid and meaningful.

![Figure 4](image)

**Fig. 4** – Flow chart of the amplifier standardization procedure. Micro volt sine waves are injected into the input of amplifiers and the frequency responses are calculated. The frequency response of the normative database amplifiers and the frequency response of other EEG amplifier systems are then equated and the spectral analysis is adjusted so that
there is a standardized import and matching of amplifier systems with the common unit being micro volts (uV).

2.4 - General Method to Produce a Valid Instantaneous Z Score EEG Database

Figure 5 is an illustration of a step by step procedure by which the Z instantaneous score normative EEG database was validated and sensitivities calculated. The left side of the figure is the edited and artifact clean and reliable digital EEG time series which may be re-referenced or re-Montaged, which is then analyzed in either the time domain or the frequency domain.

**Normative Database Validation Steps**

![Diagram of validation steps]

Fig. 5- Illustration of the step by step procedure to Gaussian cross-validate and then validate by correlations with clinical measures in order to estimate the predictive and content validity of any EEG normative database. The feedback connections between Gaussian cross validation and the means and standard deviations refers to transforms to approximate Gaussian if the non-transformed data is less Gaussian. The clinical correlation and validation arrow to the montage stage represents repetition of clinical validation to a different montage or reference or condition such as eyes-open, active tasks, eyes-closed, etc. to the adjustments and understanding of the experimental design(s). From Thatcher et al, 2003.

2.5 – Age Groupings of the Instantaneous Z Score Normative Population

The selected normal subjects are grouped by age with sufficiently large sample size and the means and standard deviations of the EEG time series and/or Frequency domain analyses are computed for each age group. Transforms are applied to
approximate a Gaussian distribution of the EEG measures that comprise the means. Once approximation to Gaussian is completed, then Z scores are computed for each subject in the database and leave one out Gaussian Cross-Validation is computed in order to arrive at an optimum Gaussian Cross-validation sensitivity. Finally the Gaussian validated norms are subjected to content and predictive validation procedures such as correlation with Neuropsychological test scores and intelligence, etc. and also discriminant analyses and neural networks and outcome statistics, etc. The content validations are with respect to clinical measures such as intelligence, neuropsychological test scores, school achievement, clinical outcomes, etc. The predictive validations are with respect to the discriminative, statistical or neural network clinical classification accuracy. Both parametric and non-parametric statistics are used to determine the content and predictive validity of a normative EEG database.

Figure 6 shows the number of subjects per year in the normative EEG lifespan database. It can be seen that the largest number of subjects are in the younger ages (e.g., 1 to 14 years, N = 470) when the EEG is changing most rapidly. As mentioned previously, a proportionately smaller number of subjects represents the adult age range
from 14 to 82 years (N = 155). The Z score normative database includes a total of 625 carefully screened individual subjects ranging in age from 2 months to 82 years. In order to increase the time resolution of age, sliding averages were used for the stratification in NeuroGuide™ and for instantaneous Z scores (Thatcher et al, 2003). Two year means were computed using a sliding average with 6 month overlap of subjects. This produced a more stable and higher age resolution normative database and a total of 21 different age groups. The 21 age groups and age ranges and number of subjects per age group is shown in the bar graph in figure 6.

3.0 - References:


4.0 - Appendix -

Complex Demodulation and Joint-Time-Frequency-Analysis

Complex demodulation is used in a joint-time-frequency-analysis (JTFA) to compute instantaneous power, coherence, amplitude asymmetry and phase-differences (Granger and Hatanaka, 1964; Ottes and Enochson, 1978; Bloomfield, 2000; Thatcher et al, 2007) and then to compute a Z score based on these instantaneous values. Complex demodulation is an analytic linear shift-invariant transform that first multiplies a time series by the complex function of a sine and cosine at a specific center frequency (see Table I) followed by a low pass filter (6th order low-pass Butterworth) which removes all but very low frequencies (shifts frequency to 0) and transforms the time series into instantaneous amplitude and phase and an “instantaneous” spectrum (Bloomfield, 2000). We place quotations around the term “instantaneous” to emphasize that, as with the Hilbert transform, there is always a trade-off between time resolution and frequency resolution. The broader the band width the higher the time resolution but the lower the frequency resolution and vice versa. Mathematically, complex demodulation is defined as an analytic transform that involves the multiplication of a discrete time series \( \{ x_t, t = 1, \ldots, n \} \) by \( \sin \omega_0 t \) and \( \cos \omega_0 t \) giving

\[
 x'_t = x_t \sin \omega_0 t \tag{1} 
\]

and

\[
 x''_t = x_t \cos \omega_0 t \tag{2} 
\]

and then apply a low pass filter \( F \) to produce the instantaneous time series, \( Z'_t \) and \( Z''_t \) where
the sine and cosine time series are defined as:

\[ Z'_t = F(x, \sin \omega_0 t) \]  
\[ Z''_t = F(x, \cos \omega_0 t) \]

and

\[ 2\left[ (Z'_t)^2 + (Z''_t)^2 \right]^{1/2} \]  
is an estimate of the instantaneous amplitude of the frequency \( \omega_0 \) at time \( t \) and

\[ \tan^{-1} \frac{Z'_t}{Z''_t} \]  
is an estimate of the instantaneous phase at time \( t \). At this step the complex demodulation transform is the same as the Hilbert transform ( Pikovsky et al, 2003, p. 362; Oppenheim and Schaefer, 1975).

The instantaneous cross-spectrum is computed when there are two time series \( \{y_t, t = 1, \ldots, n\} \) and \( \{y'_t, t = 1, \ldots, n\} \) and if \( F[\ ] \) is a filter passing only frequencies near zero, then, as above \( R_i^2 = F[y, \sin \omega_0 t]^2 + F[y, \cos \omega_0 t]^2 = |F[y, e^{i\omega t}]| \) is the estimate of the amplitude of frequency \( \omega_0 \) at time \( t \) and \( \varphi = \tan^{-1}\left( \frac{F[y, \sin \omega_0 t]}{F[y, \cos \omega_0 t]} \right) \) is an estimate of the phase of frequency \( \omega_0 \) at time \( t \) and therefore,

\[ F[y, e^{i\omega_0 t}] = R_i e^{i\varphi}, \]  

and likewise,

\[ F[y'_t, e^{i\omega_0 t}] = R'_i e^{i\varphi}. \]

The instantaneous cross-spectrum is

\[ V_i = F[y, e^{i\omega_0 t}]F[y', e^{-i\omega_0 t}] = R_i R'_i e^{i[\varphi - \varphi']} \]

and the instantaneous coherence is

\[ \frac{|V_i|}{R_i^2 R'^2} = 1 \]

The instantaneous phase-difference is \( \varphi_i - \varphi'_i \). That is, the instantaneous phase difference is computed by estimating the instantaneous phase for each time series separately and then taking the difference. Instantaneous phase difference is also the arctangent of the imaginary part of
\( V_t \) divided by the real part (or the instantaneous quadspectrum divided by the instantaneous cospectrum) at each time point.