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Introduction: 
       The signal generator is used to calibrate and test the digital signal processing 
properties of NeuroGuide as well as to serve as an educational program by which the 
principles of digital signal analyses can be learned and explored.   Concepts such as 
frequency, time, phase delays, noise, amplitude and coherence can be tested and evaluated. 
  EEG data can be simulated by approximating the selected mixtures of signals to match 
the signal parameters and scalp locations of the EEG. 
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Step #1:  Launch NeuroGuide and click File>Open>Signal Generation 
  
Return to Top 
  

 
  
  
  
  

Step #2 -    Use Mouse to Select EEG Channels, Waveforms (sine, 
sawthooth, square and pulses),  Frequencies (1 to 30 Hz), Amplitudes 
(uV), Phase Delays (degrees) and “Noise” (% S/N ratio)   
  
Return to Top 
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2a - Click a channel to select a location in Lexicor format (e.g., O1), then double click a 
Frequency (e.g., 10 Hz), then double click Amplitude (uV) and type in a value (e.g., 100 
uV). 
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2b – Mix sine waves in by double clicking the amplitude of a different frequency, e.g., 5 Hz 
and type 50 uV.  
  

 
  
  
2c – Shift the Phase of the 5 Hz signal by double clicking “Phase Shift (Deg)” at 5 Hz and 
type 30. 
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2d – Add “Noise” to the 5 Hz signal by double clicking the window below “Signal Noise 
(uV)” and type 100.  This adds 100 microvolts of noise to the 5 Hz signal located at O1. 
  

 
  
  
2e – Repeat Steps 2a to 2d for each channel with or without adding  phase delays and/or 
noise or multiple frequencies, etc.  Unselect any value by double clicking in the 
appropriate box and set the value = 0.  The Channel is the primary selection and then the 
amplitude, frequency or mixtures of frequencies and phases and noise are the secondary 
selections.   
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Step #3 - Simulate EEG "Spindles" by selecting pulse and then select 
the frequency and amplitude of the intra-pulse structure, duration 
and inter-pulse intervals of the simulated spindles.  
  
3a - Generate Pulses of different durations and inter-pulse intervals.  Use this tool to 
simulate EEG "Spindles". 

 
  
3b - Simulate any EEG by comparing the auto and cross-spectral values and then entering 
these values into the appropriate channels and appropriate parameter selection locations.  
Use the Signal Generator feature of NeuroGuide to learn about digital signal processing in 
general as well as various analytical programs including LORETA and other inverse 
solutions. 
  
  

Step # 4-  Click OK, then Click Edit>Select All to view FFT results 
  
Return to Top 
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Step #5 -  Click File>Save As to save the signals in   NeuroGuide or 
Lexicor format (*.ng or *.dat).  
  
Return to Top 
  
Step – 5a -  Follow the NeuroGuide Manual Instructions (step #6) to save as NeuroGuide 
(*.ng) or Lexicor (*.dat) files. 
  
  
Step – 5b -  Follow the NeuroGuide Manual Instructions (step # 6) to save Power Spectra 
and Cross-Spectra (Step # 6) and to Export to LORETA (Step # 11 in the NeuroGuide 
Manual). 
  
  
  

Step #6 -    Example Tutorial by replicating the publication: Gomez 
and Thatcher “Frequency domain equivalence between 
potentials and currents using LORETA.”  Int. J. of 
Neuroscience, 107: 161-171, 2001. 

  
Return to Top 
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5a- Select O1 at 10 Hz at 50 uV and 20 Hz at 25 uV 
  

 
  
  
  
5b – Select O2 at 8 Hz 50 uV and 16 Hz at 25 uV 
  

 
  
  
  
5c – Select F7 at 10 Hz 25 uV and 20 Hz at 50 uV 
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5d – Select F8 at 8 Hz 25 uV and 16 Hz at 16 uV 
  

 
  
  
  
  
5e – Click OK and then click File>Save As NeuroGuide (*.ng) or Lexicor (*.dat) for 
purposes of further analysis.  For example, save the power spectra and/or export the 
digital time series to LORETA.    
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APPENDIX – A 
Return to Top 

  
Gomez and Thatcher, 2001 used the Key Institute mathematical equations to validate LORETA 

and cross-validated their math by comparing the forward solution and the inverse solution using MRI 3-
D voxel locations and the surface scalp EEG currents and potentials (Based on the Reciprocity Theorum, 
Helmholtz, 1853).  The results of the Gomez and Thatcher, 2001 study is also consistent with Tesche, C. 
and Kajola, M.  “ A comparison of the localization of spontaneous neuromagnetic activity in the frequency 
and time domains.” Electroencephalography and Clin. Neurophysiology, 87(6): 408-416, 1993.   
           One can test the facts and the science of LORETA for themselves using the NeuroGuide signal 
generator and the Gomez and Thatcher, 2001 frequencies and locations which is only one of several tools 
available to test LORETA (see Appendix B and C) not to mention the mathematical concepts of linearity 
between frequency and time and between electrical potentials and currents (Helmholtz, 1853 physics of 
"Reciprocity" and the "Lead Field", Malmivuo and Pl onsey, 1995).    

It makes no difference whether one exports signals in the time domain or in the frequency domain 
(as demonstrated in the Gomez & Thatcher, 2001 and the Tesche et al, 1993 publications as well as by 
mathematical simulation in step # 5).  Caution must be exercised when using LORETA to be sure to 
physiologically validate using the surface linked ears, average reference and current source density data.  
This is not to indicate that LORETA is not a valid mathematical and scientific methodology, to the 
contrary, it is an important contribution.  We are emphasizing the fact that LORETA is valid when used 
by competent professionals who take the time to validate the source solutions by evaluating the surface 
EEG distributions and physiology in order to guard against localization error.  For example, scalp 
recorded EEG with large amplitude alpha in O1 and O2 should appear as high current density in areas 
17, 18 & 19 in LORETA.  
  
  

APPENDIX – B  
Mathematics and Results of Gomez & Thatcher, 2001 

  
Return to Top 
  

  
Note:  There are three instances when multiplication of matrices is communtative: 1- by a null matrix, 2- 
by an identity matrix and, 3- multiplication by a scalar.  The equation below is a valid equality when 
using a scalar as we do. 
  

                                                             Eq. 1 

  
            We apply this communtative property in the following manner. 
For S = KJ, where K is the lead field matrix, J = current and S = the sensitivity of the sensors (depending 
on the model used and the conductivity, etc.).  S is an N x W matrix for the scalp potentials (EEG/MEG), 
where N is the number of sensors and W is the number of time samples.  J is a 3M x W matrix, where M 
is the number of sources and W is the same time samples as for S.  Then the inverse solution is a linear 
combination of the signal S in the sensors 
  

J = T · S                                                                                  Eq. 2 
  
Where T is some generalized inverse of K, where the minimum norm solution is 
  
            T = (pinv(K’ · K = K)) = K’                                                    Eq. 3 
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K’  is the transpose of K, and · represents matrix multiplication and pinv(X) is the Moore-Penrose 
pseudoinverse  (Menke, 1984).  Pascual-Marqui et al, 1994 use the mathematical method that they refer 
to as “Low-Resolution Computed Tomography” (LORETA) to add physiological foundations and to 
avoid the minimum norms’s problems in localizing deep sources by using the Laplacian Operator B and 
W as a weighting matrix.  The LORETA equation is 
  
            T = {pinv(WB’BW)}K’[pinv(K inv(WB’BW)K’ }                 Eq. 4 
  
The critical factor in these considerations is that the real number FFT computed by the cross-spectrum 
(Hermitian matrix as a scalar real number) as represented in equation 1 is a linear operator such that for 
any inverse solution of the form in equation 3 is equivalent to: 
  
            FFT(J) = FFT [T · S] = T · FFT[S]                                         Eq. 5 
  
Equation 5 is the formula that Gomez and Thatcher (2001) used.  Gomez and Thatcher (2001) simulated 
the linear equivalence by a combination of sine waves and confirmed the linearity of equation 5 as any 
one can do by using the NeuroGuide signal generator as described in step # 5 for oneself. 
  
  
  
Figure 1 – From Gomez & Thatcher, 2001.  This is the three-shell spherical model of the head used to 
simulate LORETA.  Four electrodes (F7, F8, O1, O2) and the reference electrode (A1) are indicated by 
black rectangles.  The coordinates of the electrodes are according to the best-fitting sphere relative to 
cortical anatomy (Towel et al., 1993).  The peaks of beta (for F7 and F8) and alpha activity (for O1 and 
O2) are indicated in parenthesis.  Eight sources (1 to 3) indicated by black circles were located in the 
interior of the sphere to represent the equivalent current sources such as in the gray matter. 
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Figure 2 – From Gomez & Thatcher, 2001.  Power spectrum of the signals used to simulate LORETA.  
The spectrum of the signals in the scalp electrodes is shown on the left (amplitude of beta is higher in the 
anterior regions, alpha amplitude is higher in the posterior regions and a frequency shift toward the 
lower frequencies in the right hemisphere).  The center and right columns are the spectra of the current 
sources nearest to the electrodes J1, J3, J5 and J7 after calculating the inverse solution.  Each source has 
three components x, y and z.  The y-axis of the electrodes is uv2 /cycle/sec for the electrodes and uA/cm2 )
2 /cycle/sec for current density at each source location.  The x-axis is frequency in Hz in all cases.  This 
simulation confirms the mathematical statements and demonstrates a frequency domain equivalence 
between the spectra of electrical potentials at the scalp and the spectra of currents in the interior of the 
head model. 
  

 
  
  

  
  

APPENDIX – C  - REFERENCES 
Return to Top 
  
Baillet, S., et al, “Evaluation of inverse methods and head models for EEG source localization using a 
human skull phantom”.  Physics in Medicine and Biology, 46: 77-96, 2001. 
  
Baillet, S. and Garnero, L.  “A Bayesian approach to introducing anatomo-functional priors in the EEG, 
MEG inverse problem”.  IEEE Trans. Biomed. Eng. 44: 374-375, 1997.  
  
Casper, et al.  “Evaluation of inverse methods and head models for EEG source localization using a 

Page 13 of 14Signal Generator Manual

2/9/2009file://C:\Users\Robert Thatcher\AppData\Local\Temp\~hhC0AC.htm



human skull phantom”  at: http://sipi.usc.edu/~silvin/docs/inversecasperthese2.pdf 
  
Gomez, J. F. and Thatcher, R.W. “Frequency domain equivalence between potentials and currents using 
LORETA.”  Int. J. of Neuroscience, 107: 161-171, 2001. 
  
Helmholtz, HLF, Ann. Physik and Chemie 89: 211-233, 354-377, 1853 (see also "Helmholtz's Treatise on 
Physiological Optics"  by Hermann Von Helmholtz, edited by J. P. Southal, Thoemmes, Press, 2000, 
ISBN 1855068311). 
  
Malmivuo, J. and Plonsey, R. "Bioelectromagnetism", Oxford University Press, 1995. 
  
Menke, W. “Geophysical Data Analysis: Discrete Inverse Theory.”  Orlando: Academ,ic Press, 1984. 
  
Hämäläinen, M. “Discrete and distributed source estimates”,ISBET Newsletter  Edited by W. Skrandies, 
Giessen, Germany, No 6 / December 1995. 
  
Pascual-Marqui, R. D.  Review of methods for solving the EEG inverse problem.  Inter. J. of 
Bioelectromagnetism, 1:75-86, 1999. 
  
Tesche, C. and Kajola, M.  “A comparison of the localization of spontaneous neuromagnetic activity in 
the frequency and time domains.” Electroencephalography and Clin. Neurophysiology, 87(6): 408-416, 
1993.   
  
Towel, V. et al.,  The spatial location of EEG electrodes: locating the best-fitting sphere relative to cortical 
anatomy.  EEG & Clin. Nerurophysiol., 103: 9 – 15, 1993. 
  

Return to Top 

Page 14 of 14Signal Generator Manual

2/9/2009file://C:\Users\Robert Thatcher\AppData\Local\Temp\~hhC0AC.htm


